Does your web host offer multiple versions of php?

211px-Webysther_20160423_-_Elephpant.svgWhat is php? Why is having access to use multiple versions of php so important? Does XYZulu offer multiple versions of php?

What is PHP?

According to Wikipedia, “PHP is a general-purpose scripting language that is especially suited to server-side web development, in which case PHP generally runs on a web server. Any PHP code in a requested file is executed by the PHP runtime, usually to create dynamic web page content or dynamic images used on websites or elsewhere.”

Why should you be interested in this?

your website will load faster, and run more efficiently if you are using PHP 7

Your website will load faster, and run more efficiently if you are using PHP 7. Think of is as the fuel that powers the engine your website uses. Use the right fuel, and your web site will run at it’s best.

Oh, and in case you were wondering, that elephant is the official PHP mascot. 🙂

Why is having access to use multiple versions of php so important?

PHP is constantly being updated and deployed on web servers around the world. Usually these updates are to patch security holes and optimize the delivery of website content. Each new version of PHP however, usually brings a greater jump in speed as well as well as additional features for developers. A case in point is PHP 7, which is a big jump forward in performance.

Most major scripts like Joomla, WordPress and Drupal already support PHP 7. Utilizing the performance improvements is as simple as ensuring your website scripts (Joomla, WordPress etc) are up to date and enabling PHP 7.

Aside from the benefits of PHP 7, having access to multiple versions of PHP also means that you can run scripts that support older versions of PHP as well as the latest version of PHP. The choice is up to you. A shared web host that is not running multiple versions of PHP yet, is probably one to avoid for security and performance reasons.

Does XYZulu.hosting offer multiple versions of php?

XYZulu Hosting offers multiple versions of PHP

Yes! You can choose your version of PHP from cPanel > Select PHP version. If you need a hand checking to see if your script or website supports PHP 7, please be sure to contact us from our Support Portal.

comments, feedback & questions